C MIT

media-server

RTSP/RTP/RTMP/FLV/HLS/MPEG-TS/MPEG-PS/MPEG-DASH/MP4/fMP4/MKV/WebM

I

ireader

Dernière activité 26 mai 2026
ireader/media-server

3,5 k

étoiles

1,2 k

forks

108

issues ouvertes

flvfmp4hlsm3um3u8mkvmp4mpeg-dashpsrtmprtprtspsdpsiptswebm

Ce README est souvent en anglais.

libflv

  1. FLV video codec: H.264/H.265/H.266/AV1/VP8/VP9/VP10
  2. FLV audio codec: AAC/MP3/G.711/Opus
  3. FLV file read/write
  4. H.264/H.265/H.266/AV1 bitstream filter: annex-b <-> mp4 stream
  5. AAC bitstream filter: ADTS <-> ASC

librtmp

  1. rtmp-client: RTMP publish/play
  2. rtmp-server: RTMP Server live/vod streaming

libmpeg

  1. ITU-T H.222.0 PS/TS read/write
  2. ps/ts codec: H.264/H.265/H.266/AAC/MP3/G.711/Opus

librtp

  1. RFC3550 RTP/RTCP
  2. RTP with H.264/H.265/H.266/MPEG-2/MPEG-4/VP8/VP9/AV1
  3. RTP with G.711/G.726/G.729/MP3/AAC/Opus
  4. RTP with MPEG-2 PS/TS
  5. RTP Header Extension
  6. RTCP PSFB/RTPFB/XR

librtsp

  1. RFC2326 RTSP
  2. RFC4566 SDP
  3. SDP fmtp: H.264/H.265/H.266/AAC/Opus/G.711

libhls

  1. HLS M3U8: generate m3u8 file
  2. HLS Media: TS segmenter
  3. HLS fmp4 segmenter
  4. HLS Master/Playlist m3u8 parser

libdash

  1. ISO/IEC 23009-1 MPEG-DASH static(vod)
  2. ISO/IEC 23009-1 MPEG-DASH dynamic(live)
  3. DASH MPD v3/v4 parser

libmov

  1. ISO/IEC 14496-12 MP4 File reader/writer
  2. MP4 faststart(moov box before mdat)
  3. fMP4(Fragment MP4) writer
  4. MP4 with H.264/H.265/H.266/AV1/VP8/VP9/JPEG/PNG
  5. MP4 with AAC/Opus/MP3/G.711

libmkv

  1. MKV/WebM file read/write
  2. MKV/WebM live streaming

libsip

  1. sip user-agent (UAC/UAS)
  2. sip with ICE
  1. HTTP Server(base AIO)
  2. HTTP Client
  3. HTTP Cookie

Make

  1. make clean && make
  2. make RELEASE=1 (make release library, default debug)
  3. make PLATFORM=arm-hisiv100nptl-linux (cross compile)

友情链接

ZLMediaKit 基于C++11的高性能运营级流媒体服务框架
MediaInsight360 流媒体格式在线解析

Projets similaires

Mirror of https://git.ffmpeg.org/ffmpeg.git

Caudiocffmpeg
FFFmpeg
64,6 k étoiles14,3 k

SRS is a simple, high-performance, AI-driven real-time media server supporting RTMP, WebRTC, HLS, HTTP-FLV, HTTP-TS, SRT, MPEG-DASH, and GB28181, with codec support for H.264, H.265, AV1, VP9, AAC, Opus, and G.711.

C++ai-drivenaudioc-plus-plus
Oossrs
29,3 k étoiles5,7 k

WebRTC/RTSP/RTMP/HTTP/HLS/HTTP-FLV/WebSocket-FLV/HTTP-TS/HTTP-fMP4/WebSocket-TS/WebSocket-fMP4/GB28181/SRT/STUN/TURN server and client framework based on C++11

C++flvgb28181hls
ZZLMediaKit
17,6 k étoiles4,1 k